Chitipat Phetmunee
2 weeks ago

How to set up the environment for BG101: Intro to Ethereum?

2 weeks ago
0
0

I try to do follow the setup that shows in the video but it has an error.
It shows the message like this.

lerna info version 2.6.0
lerna info Bootstrapping 19 packages
lerna info lifecycle preinstall
lerna info Installing external dependencies
lerna ERR! execute callback with error
lerna ERR! Error: Command failed: npm install
lerna ERR! npm WARN deprecated minimatch@0.3.0: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
lerna ERR! gyp ERR! configure error
lerna ERR! gyp ERR! stack Error: Python executable “/Users/chitipatphetmunee/anaconda3/bin/python” is v3.6.3, which is not supported by gyp.
lerna ERR! gyp ERR! stack You can pass the –python switch to point to Python >= v2.5.0 & < 3.0.0.
lerna ERR! gyp ERR! stack at PythonFinder.failPythonVersion (/usr/local/lib/node_modules/npm/node_modules/node-gyp/lib/configure.js:492:19)
lerna ERR! gyp ERR! stack at PythonFinder. (/usr/local/lib/node_modules/npm/node_modules/node-gyp/lib/configure.js:474:14)
lerna ERR! gyp ERR! stack at ChildProcess.exithandler (child_process.js:264:7)
lerna ERR! gyp ERR! stack at ChildProcess.emit (events.js:159:13)
lerna ERR! gyp ERR! stack at maybeClose (internal/child_process.js:943:16)
lerna ERR! gyp ERR! stack at Socket.stream.socket.on (internal/child_process.js:363:11)
lerna ERR! gyp ERR! stack at Socket.emit (events.js:159:13)
lerna ERR! gyp ERR! stack at Pipe._handle.close [as _onclose] (net.js:568:12)
lerna ERR! gyp ERR! System Darwin 17.0.0
lerna ERR! gyp ERR! command “/usr/local/bin/node” “/usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js” “rebuild”
lerna ERR! gyp ERR! cwd /Users/chitipatphetmunee/setup/node_modules/web3/packages/web3-eth-accounts/node_modules/scrypt
lerna ERR! gyp ERR! node -v v9.3.0
lerna ERR! gyp ERR! node-gyp -v v3.6.2
lerna ERR! gyp ERR! not ok
lerna ERR! npm WARN web3-eth-accounts No repository field.
lerna ERR! npm WARN web3-eth-accounts No license field.
lerna ERR!
lerna ERR! npm ERR! code ELIFECYCLE
lerna ERR! npm ERR! errno 1
lerna ERR! npm ERR! scrypt@6.0.3 install: `node-gyp rebuild`
lerna ERR! npm ERR! Exit status 1
lerna ERR! npm ERR!
lerna ERR! npm ERR! Failed at the scrypt@6.0.3 install script.
lerna ERR! npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
lerna ERR!
lerna ERR! npm ERR! A complete log of this run can be found in:
lerna ERR! npm ERR! /Users/chitipatphetmunee/.npm/_logs/2018-01-09T08_26_21_379Z-debug.log
lerna ERR!
lerna ERR! > scrypt@6.0.3 preinstall /Users/chitipatphetmunee/setup/node_modules/web3/packages/web3-eth-accounts/node_modules/scrypt
lerna ERR! > node node-scrypt-preinstall.js
lerna ERR!
lerna ERR!
lerna ERR! > scrypt@6.0.3 install /Users/chitipatphetmunee/setup/node_modules/web3/packages/web3-eth-accounts/node_modules/scrypt
lerna ERR! > node-gyp rebuild
lerna ERR!
lerna ERR!
lerna ERR! at Promise.all.then.arr (/Users/chitipatphetmunee/setup/node_modules/lerna/node_modules/execa/index.js:236:11)
lerna ERR! at
(node:4102) UnhandledPromiseRejectionWarning: Error: Command failed: npm install
npm WARN deprecated minimatch@0.3.0: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
gyp ERR! configure error
gyp ERR! stack Error: Python executable “/Users/chitipatphetmunee/anaconda3/bin/python” is v3.6.3, which is not supported by gyp.
gyp ERR! stack You can pass the –python switch to point to Python >= v2.5.0 & < 3.0.0.
gyp ERR! stack at PythonFinder.failPythonVersion (/usr/local/lib/node_modules/npm/node_modules/node-gyp/lib/configure.js:492:19)
gyp ERR! stack at PythonFinder. (/usr/local/lib/node_modules/npm/node_modules/node-gyp/lib/configure.js:474:14)
gyp ERR! stack at ChildProcess.exithandler (child_process.js:264:7)
gyp ERR! stack at ChildProcess.emit (events.js:159:13)
gyp ERR! stack at maybeClose (internal/child_process.js:943:16)
gyp ERR! stack at Socket.stream.socket.on (internal/child_process.js:363:11)
gyp ERR! stack at Socket.emit (events.js:159:13)
gyp ERR! stack at Pipe._handle.close [as _onclose] (net.js:568:12)
gyp ERR! System Darwin 17.0.0
gyp ERR! command “/usr/local/bin/node” “/usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js” “rebuild”
gyp ERR! cwd /Users/chitipatphetmunee/setup/node_modules/web3/packages/web3-eth-accounts/node_modules/scrypt
gyp ERR! node -v v9.3.0
gyp ERR! node-gyp -v v3.6.2
gyp ERR! not ok
npm WARN web3-eth-accounts No repository field.
npm WARN web3-eth-accounts No license field.

npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! scrypt@6.0.3 install: `node-gyp rebuild`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the scrypt@6.0.3 install script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR! /Users/chitipatphetmunee/.npm/_logs/2018-01-09T08_26_21_379Z-debug.log

> scrypt@6.0.3 preinstall /Users/chitipatphetmunee/setup/node_modules/web3/packages/web3-eth-accounts/node_modules/scrypt
> node node-scrypt-preinstall.js

> scrypt@6.0.3 install /Users/chitipatphetmunee/setup/node_modules/web3/packages/web3-eth-accounts/node_modules/scrypt
> node-gyp rebuild

at Promise.all.then.arr (/Users/chitipatphetmunee/setup/node_modules/lerna/node_modules/execa/index.js:236:11)
at
at process._tickCallback (internal/process/next_tick.js:160:7)
(node:4102) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). (rejection id: 4)
(node:4102) [DEP0018] DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will terminate the Node.js process with a non-zero exit code.
npm WARN setup No description
npm WARN setup No repository field.
npm WARN setup No license field.

npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! web3@1.0.0-beta.18 postinstall: `lerna bootstrap`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the web3@1.0.0-beta.18 postinstall script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR! /Users/chitipatphetmunee/.npm/_logs/2018-01-09T08_26_31_504Z-debug.log

Comments

There are no comments yet